欢迎进入jdb电子官方网站!

咨询热线:400-156-4567

Springboot项目报错 【错误:java: 错误: 不支持发行版本 17】

发布时间:2024-01-31 11:05:36

项目场景:springboot项目build完成后运行出错

使用IDEA的Spring Initializr构建的Spring boot项目在构建完成后运行出错

问题描述

用Spring Initializr创建了Spring Boot 项目后,运行时报错“错误:java: 错误: 不支持发行版本 17”


原因分析:

根据错误信息得知,应该是JDK的版本出了问题,查看pom.xml检查一下

可以看到,JDK的版本是17,由于我并没有安装JDK17,所以会报错不支持发行版本17,但是在我用Spring Initializr创建项目时选的是JDK11,为什么创建成功就变成17了呢,这里检查一下Spring Boot 的版本

这下就清楚了,应该是Spring Boot的版本和Java版本不兼容的问题,查了一下Spring Boot 3.0.4支持的最低Java 版本为JDK 17,在创建项目时应该是忽略了我指定的JDK版本,而是选择了满足条件的最低的JDK,又因为我没有安装这个版本所以报错。


解决方案:

在创建项目时选择较低版本的Spring Boot即可


Spring Boot和JDK版本的对应关系可以自行搜索。